python html5 bootstrap 视频教程

德云社区

 找回密码
 立即注册

扫一扫,访问微社区

QQ登录

只需一步,快速开始

数字 IDE 网页 ── \"所见即所得\" 编写 HTML4、HTML5 静态 \"网站站群\" 动态网站,生成 Robots、站点地图,死链检测,强大文本编辑器功能。。。集成中英自动 TTS 文本诵读功能。。。
数字 IDE Python ── 支持 \"极速编写-重构\" Python、Django、HTML5、XML、C/C++、Java、Perl、PHP、Ruby、C#、VB .Net 等程序源代码。。。集成了很多常用编程智能辅助工具。。。
业务范围:
01、企业 \"内部 | 外部\" 数据管理、分析、挖据
02、企业效率优化专用 APP 程序定制、IT 外包
03、智能数字化系统平台架设、开发、部署、维护
04、高仿真、低成本,可动画-可 VR 数字样机建模、开发、规划
05、企业 Linux 云计算 \"IaaS | SaaS\" 服务器架设、开发、部署、维护
06、\"标准 | 非标\" 设备全流程研发,PLC、单片机、工控系统开发、集成
07、企业 Linux / Windows 平台 PLM、ERP 系统架设、开发、部署、维护
08、企业 Linux / Windows 平台 \"内网 | 外网\" 服务器架设、开发、部署、维护
09、企业微信公众号智能互动营销、策划,Web 网站代码、SEO 排名优化,大数据网络推广
10、企业跨平台、跨硬件、跨浏览器 HTML5 Web 电子商务平台、\"静态 | 动态\" 网站开发、部署、维护
11、企业文档、资料、公司网页多语种翻译,数据资料标准化、版本化、数字化管理的规划、研发、实施
数字翻译 ── 能 \"批量翻译\" 文档 GUI 用户界面。。。网页浏览 批处理 全文搜索 全文替换 全文删除 全文插入 数据比较 。。。集成中英自动 TTS 文本诵读功能。。。
查看: 759|回复: 0

浅谈Windows平台与Ubuntu 14.04下python程序版本的大致选用区别

[复制链接]

155

主题

157

帖子

952

积分

高级技师

Rank: 4

金钱
595
金币
19
威望
0
贡献
0
发表于 2015-8-23 01:51:52 | 显示全部楼层 |阅读模式
|          
浅谈Windows平台与Ubuntu 14.04下python程序版本的大致选用区别

Python([ˈpaɪθən])是一种面向对象、解释型计算机程序设计语言。Python语法简洁、清晰,具有丰富和强大的类库。


Python源代码遵循GPL(GNU General Public License)协议,由Guido van Rossum于1989年底发明,第一个公开发行版发行于1991年。


Python常被称为胶水语言,能把用其他语言编写的各模块(尤其是C/C++)轻松地联结在一起。常见情形是,用Python快速生成程序原型(有时甚至是程序最终界面),然后对其中有特别要求的部分,用更合适的语言改写;譬如:3D游戏中的图形渲染模块,性能要求特别高,就可用C/C++重写,而后封装为Python可调用的扩展类库。需要注意的是,在您使用扩展类库时可能需要考虑平台问题,某些扩展类库可能不提供跨平台实现。


Ubuntu 14.04

Ubuntu 14.04 Server 及 Desktop 版集成了python 2.7.6 与 python 3.4.0。


当在 Shell 中键入 python,会运行 Python 2.7.6,键入 python3 会运行 Python 3.4.0。


  1. root:# python
  2. Python 2.7.6 (default, Jun 22 2015, 17:58:13)
  3. [GCC 4.8.2] on linux2
  4. Type "help", "copyright", "credits" or "license" for more information.
  5. >>> exit()
  6. root:# python3
  7. Python 3.4.0 (default, Jun 19 2015, 14:20:21)
  8. [GCC 4.8.2] on linux
  9. Type "help", "copyright", "credits" or "license" for more information.
  10. >>> exit()
  11. root:#
复制代码

Windows

Windows 平台当然没有集成任何版本的 python,得单独另外安装。


但 python 版本众多,选择哪一个安装版本,就是一门要做不少功课的小学问。


譬如:若想学习操控百度云与新浪云产品,最好安装与之相对应的 python 2.7.3;若想二次开发 OpenERP 7 或 Odoo 8,当然得安装 python 2.7.6;若想开发 Cinema 4D 脚本插件,就得安装 python 2.6.4。


若没任何特殊要求,当然首选安装 python 2.7 系列版本,与之兼容的现成模块最多。python 3 系列版本因历史及语言的一些变化问题,建议不要采用,当然,未来还是属于 python 3 的。


若要安装 python 2.7 系列版本,建议采用 python 2.7.8,原因何在。譬如:python 2.7.3 版本有点老,python 2.7.6 没有如下所示的 python.exe 路径变量


Ashampoo_Snap_2015.08.23_03h52m21s_004_.jpg

使用时,有点不太方便。因使用时,要键入 python.exe 的完整路径,而不是仅输入 python 即可。


若真要这样,可在 Path 系统变量中加入 D:\Python27\; 或 C:\Python27\; 即可。


Ashampoo_Snap_2015.08.23_03h57m36s_005_.jpg

集成此系统变量的安装包是从 python 2.7.7 起。


由于从 python 2.7.9 起,程序安装包大小发生了较大变化,功能也有所变化;由此原因,某些老模块包,或将出现不兼容性问题,建议暂时不要采用。

编译型语言
Ashampoo_Snap_2015.08.23_03h47m37s_002_.jpg

版权声明:

本文为独家原创稿件,版权归 德云社区,未经许可不得转载;否则,将追究其法律责任。
AI人工智能 语音助理 人工翻译 教程
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|Sitemap|手机版|小黑屋| |网站地图  

GMT+8, 2018-10-19 20:31 , Processed in 0.050602 second(s), 34 queries .

技术支持 乐数软件  版权所有 © 2014-2019 德云社区

工业和信息化部:粤ICP备14079481号-2

快速回复 返回顶部 返回列表